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Objectives

By the end of this exercise, you will: 
• Know where to access SAR data
• Know how to use the Sentinel-1 Toolbox to process SAR data
• Be able to generate a flooding classification from a SAR image
• Be able to use Google Earth Engine to generate flood 

classifications from SAR images
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Requirements

• Sentinel Toolbox installed in your computer
– http://step.esa.int/main/download/
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Note

This is a three-part exercise:

• Part 1 will focus on access and processing of Sentinel-1 SAR data

• Part 2 will focus on generating a flood classification using SNAP

• Part 3 will focus on generating a flood classification using Google Earth Engine
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Part 1: Outline

• Download Sentinel-1 images through the Alaska Satellite Facility 
website

• Subset the image

• Perform radiometetric correction

• Apply a speckle filter

• Perform geometric correction
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• Sentinel-1
– Two satellites: A & B
– Each satellite has 

global coverage 
every 12 days

– Global coverage of 6 
days over the equator 
when using data from 
both satellites

Sentinel-1 Coverage
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Sentinel-1: Modes of Aquisition

1. Extra Wide Swath – for 
monitoring oceans and coasts

2. Strip Mode – by special order 
only and intended for special 
needs

3. Wave Mode – routine collection 
for the ocean

4. Interferometric Wide Swath –
routine collection for land
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• Alaska SAR Facility
– http://www.asf.alaska.edu/sentinel/

• European Space Agency Portal
– http://sentinel.esa.int/web/sentinel-data-access/access-to-sentinel-

data/

How to Access Sentinel-1 Images

http://www.asf.alaska.edu/sentinel/
http://sentinel.esa.int/web/sentinel-data-access/access-to-sentinel-data/


National Aeronautics and Space Administration 9Applied Remote Sensing Training Program

• An open source software developed by ESA for processing and analyzing 
radar images from different satellites

• Includes the following tools
– Calibration
– Speckle noise
– Terrain correction
– Mosaic production
– Polarimetry
– Interferometry
– Classification

Sentinel-1 Toolbox



Accessing, Opening and Displaying SAR 
Data
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Accessing Sentinel-1 Data
1. Go to the Alaska Satellite Facility Sentinel Data Portal: https://vertex.daac.asf.alaska.edu/

2. Identify your area (76.77,7.97,77.41,8.25,76.9,10.31,76.18,9.43,76.77,7.97) 

3. Identify images of interest (Sentinel-1 A/B) 

4. Click on “Optional Search Criteria” and specify July 1, 2018-Aug. 30, 2018

5. Click on “Search” at the bottom of the page

6. Select granule S1A_IW_GRDH_1SDV_20180704T004106_20180704T004131_022637_0273E1_B4B0 
from Jul. 4, 2018. Path 165 Frame 563. This image represents conditions before the flood.

7. Download the L1 Detected High-Res Dual-Pol (GRD-HD) Product

8. Select granule S1A_IW_GRDH_1SDV_20180821T004109_20180821T004134_023337_0289D5_B2B2 
from Aug. 21, 2018. Path 165 Frame 563. This image represents conditions after the flood.

9. Download the L1 Detected High-Res Dual-Pol (GRD-HD) Product

https://vertex.daac.asf.alaska.edu/
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Accessing Sentinel-1 Data
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Opening the Data with the Sentinel Toolbox

1. Initiate the Sentinel Toolbox by clicking on its desktop icon
2. In the Sentinel Toolbox interface, go to the File menu and 

select Open Product
3. Select the folder containing your Sentinel-1 file, and double 

click on the .zip file (do not unzip the file; the program will do 
it for you). Open the second file
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Opening the Data with the Sentinel Toolbox
4. The Product Explorer window of the Sentinel Toolbox 

contains your file. Double click on the file to view the 
directories within the file, which contain information 
relevant to the image, including:

• Metadata: parameters related to orbit and data

• Tie Point Grids: interpolation of latitude/longitude, 
incidence angle, etc.

• Bands: intensity and amplitude (intensity is the 
amplitude squared)

5. The Worldview window (lower left) shows the footprint of 
the image selected. Note that it is inverted because it is 
oriented in the same way it was acquired.
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Opening the Data with the Sentinel Toolbox- RGB Image

6. Go back to the Product Explorer tab
7. Select the file name of the first Sentinel-1 dataset. Afterwards, select Open RGB Image 

Window to display a color image of VV, VH, and VV/VH ratio
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Opening the Data with the Sentinel Toolbox- Pixel Information

In the upper left window select “Pixel Info” to see the value and the lat/lon of 
each pixel in the image opened



Preprocessing
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Data Preparation

Select “Raster” and then “Subset”. Repeat the subset for the 2nd image.

Defining a Subset
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• The objective in performing a calibration is to create an image where the 
value of each pixel is directly related with the backscatter of the surface. 

• This process is essential for analyzing the images in a quantitative way. It is also 
important for comparing images from different sensors, modalities, processors 
or acquired at different times.

Preprocessing: Geometric and Radiometric Calibration
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The main radiometric 
distortions are due to: 

1. Signal loss as it 
propagates

2. Non-uniform antenna 
pattern

3. Difference in gain

4. Saturation

5. Speckle

Example: Preprocessing – Radiometric Calibration
Select “Radar- Radiometric- Calibrate”. Run on each subset.
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• Speckle is part of radar 
images and makes 
interpretation difficult 
because the “salt and 
pepper” effect corrupts 
information about the 
surface

• There are many techniques 
to extract information from 
radar images that have lots 
of speckle
– In this case, we will use 

the Lee filter

Example: Preprocessing – Speckle Filter
Select “Radar- Speckle Filtering- Single Product”. Apply to each subset.
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The main geometric distortions 
are due to: 

1. Slant Range

2. Layover

3. Shadow

4. Foreshortening

• The algorithm uses a DEM to 
make corrections

• The corrected image is in its 
correct orientation

Example: Preprocessing – Geometric Calibration
Select “Radar- Geometric- Terrain Correction- Range Doppler”
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Example: Preprocessing – Geometric Calibration
Select “Radar- Geometric- Terrain Correction- Range Doppler”
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Data Preparation

Select “Radar>Coregistration>Stack Tools>Create Stack

Stack the two images
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Data Preparation
Stack the two images

Load images

Specify ”Product Geolocation”
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Data Preparation
Create a Multi-temporal RGB

R- Jul. 4 VV
G- Aug. 21 VH
B- Aug. 21 VV
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Data Preparation
Convert Values to dB and “Convert Band” so that the dB image created is 
saved. Repeat for all bands within the stack.



Applying a Threshold to Separate Water and 
Land
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Classifying Water and Land by Creating a Threshold

1. Load the Aug. 21 VH dB 
image and analyze the 
image histogram in the 
lower left window

2. Identify a threshold 
between high values and 
low values

3. Select the value that 
separates water from 
everything else. In this case 
-19.39 dB
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1. To segment the image, apply 
band math

2. Edit the expression so that it 
indicates:

255*(Sigma0_VH<-19.39)
3. The result will be an image 

where water will have a value 
of 255. Call this new image 
“water”

Classifying Water and Land by Creating a Threshold

Select “Raster- Band- Math”
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Threshold Result to Separate Water and Land
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Result: Threshold to Separate Water and Land

To change the 
colors, go to the 
color manipulation 
window on the 
bottom left and 
select Table. There 
you can assign a 
color to each of the 
3 classes.



Supervised Classification
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Training Area Selection

1. Select training areas by:
– displaying the image as RGB
– selecting from the main menu Vector>New Vector Data Container and 

providing a name for your first training class (in this case permanent water)
– in the Tools menu along the top bar, select the Polygon Drawing Tool  
– create a polygon of the area representative of open water.
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Training Area Selection

2. Define the remaining training areas:
– Repeat these same steps for each class. 

• flood water, dry land, wet land
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Running the Random Forest Classifier

3. Run the Random Forest Classification by:
– selecting in the top menu Raster >Classification>Supervised Classification > 

Radom Forest Classifier
– in the pop-up window, select the file that you want to classify. To load it, select 

the add-opened files on the column on the right (the second one down). 
Load the calibrated, speckle filtered, terrain corrected file.

– The second tab, Random Forest Classifier, will have a list of the training areas 
selected. Keep the defaults. Run it.
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Running the Random Forest Classifier

4. Display the results:
– a new image with extension _RF will be added in the product explorer 

window. Display the bands>labeled classes image.
– In the color manipulation tab of the bottom left window, assign the desired 

colors to each class.
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Running the Random Forest Classifier

5. Accuracy assessment:
– while Random Forest is running, a separate text window will display the 

classification validation results:
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Refining Your Classification Results

6. Refine the classification results by applying a filter:
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Refining Your Classification Results

7. Go to the Color Manipulation Window

Under the “Table” tab assign numbers and colors to your classes



National Aeronautics and Space Administration 41Applied Remote Sensing Training Program

Refined Classification Results



Google Earth Engine
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Metadata and Filtering

https://code.earthengine.google.com/
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Sentinel-1 Preprocessing on Google Earth Engine
• Google Earth Engine uses the following preprocessing steps (as implemented by the Sentinel-1 

Toolbox) to derive the backscatter coefficient in each pixel:

• Apply orbit file
– Updates orbit metadata with a restituted orbit file.

• GRD border noise removal
– Removes low intensity noise and invalid data on scene edges. (As of January 12, 2018)

• Thermal noise removal
– Removes additive noise in sub-swaths to help reduce discontinuities between sub-swaths for 

scenes in multi-swath acquisition modes. (This operation cannot be applied to images produced 
before July 2015)

• Radiometric calibration
– Computes backscatter intensity using sensor calibration parameters in the GRD metadata.

• Terrain correction (orthorectification)
– Converts data from ground range geometry, which does not take terrain into account, to σ°

using the SRTM 30 meter DEM or the ASTER DEM for high latitudes (greater than 60° or less than -
60°).

https://sentinel.esa.int/web/sentinel/toolboxes/sentinel-1
https://qc.sentinel1.eo.esa.int/aux_resorb/
https://code.earthengine.google.com/dataset/USGS/SRTMGL1_003
https://asterweb.jpl.nasa.gov/gdem.asp
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Flood Mapping
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Flood Mapping Results


