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Objectives & Learning Outcomes

• In this section you will learn: 
– Collocate Bands
– Band Math (Math Band)
– Statistics
– Filter Band
– Pixel Extraction
– Combine (Mosaic) Two Images

https://arset.gsfc.nasa.gov/
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Beginning Steps

1. Open SeaDAS
2. Navigate to the Part 1 exercise folder you created in the first week
3. Recall that you reprojected and cropped a subset of data from the original L2 

files for OC, SST, and IOP. The names of the files are as follows:
– A2015051184000.L2_LAC_OC_reprojected_subset.dim (and supporting .data 

file)
– A2015051184000.L2_LAC_SST_reprojected_subset.dim (and supporting .data 

file)
– A2015051184000.L2_LAC_IOP_reprojected_subset.dim (and supporting .data 

file)

https://arset.gsfc.nasa.gov/
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Important Note

• These reprojected_subset image files all need to be cropped with the same 
geographic coordinates

• If your reprojected_subset images are not cropped along the same geographic 
coordinates across all files, then the following collocate bands steps will fail

• If you need to repeat the cropping step in Exercise 1, do so now
• For the Part 1 exercise, we used the following geographic coordinates North = 

30.485, South = 25.986, West = -84.551, East = -81.739
• You don’t have to use those coordinates, just be consistent across all of the files

https://arset.gsfc.nasa.gov/
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Beginning Steps

4. Create a new folder named SeaDAS_adv_skills and copy the .dim and .data 
files for these reprojected subset files into that new folder

https://arset.gsfc.nasa.gov/
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Collocate Bands

• When you wish to combine bands from different files for a given 
scene, use the collocate tool. In this example, we are combining the 
SST, IOP, and OC data. 

1. From the SeaDAS_adv_skills folder, open: 
– A2015051184000.L2_LAC_OC_reprojected_subset.dim
– A2015051184000.L2_LAC_SST_reprojected_subset.dim
– A2015051184000.L2_LAC_IOP_reprojected_subset.dim

2. In SeaDAS, at the menu bar, click on Raster > Collocate
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Collocate Bands

3. This will open a window. Select the OC 
file as the Reference File and the SST 
file as the Dependent File. 

4. Confirm that your entries for 
Reference File, Dependent File, and 
Output Name match what you see in 
the image to the right. 

5. Click Run and wait a moment
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Collocate Bands

6. Repeat the collocate step using this 
newly collocated file as the 
Reference File and the IOP file as the 
Dependent File. 

7. Confirm that your entries for 
Reference File, Dependent File, and 
Output Name match what you see in 
the image to the right. 

8. Click Run and wait a moment
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Collocate Bands

9. When processing is complete, close all files 
except the newest file: A2015051184000.L2
_LAC_OC_SST_IOP_reprojected_subset.dim 

10. Click on the Rasters folder in the File 
Manager

– Note the bands from both files are now in 
this one

– Data products from the reference file are 
appended with “R” and the dependent 
file are appended with “D”

11. View the chlor_a_R_R band
12. Try opening other bands and exploring this 

region on the West Florida Shelf and 
Suwannee River Mouth
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Collocate Bands

13. If you prefer to reduce the number of 
bands in this file, you can use the 
Raster > Crop… tool 

14. Select Band Subset instead of 
Spatial Subset, as used earlier

15. Use the Crop > Band Subset tool to 
create a new file that includes the 
following bands

16. This will create a new file that will be visible in the File Manager
pane to the right. Be sure to right click on the file and save it with a 
new name: A2015051184000.L2_LAC_combined.dim

17. Close all of the other files and explore this one by opening the 
chlorophyll, SST, and adg_443_giop data layers

18. Close all of the image layers in the viewing window
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Band Math (Math Bands)

• Sometimes it is useful to gain insight from imagery by performing 
math on the bands

• NASA uses a number of chlorophyll algorithms because conditions 
vary regionally and different algorithms are tuned for different 
regions

• The data product we’ve been focused on during these exercises is 
named chlor_a, but there are other algorithms

• A more detailed description of a number of algorithms, including 
chlor_a, can be found here: 
– https://oceancolor.gsfc.nasa.gov/atbd/chlor_a/
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Band Math (Math Bands)

• For this band math section of the exercise, we will compute the 
Color Index (CI), which can be used as an intermediate step to 
compute chlorophyll

• The CI equation: 

• The Rrs wavelengths in the CI equation above map to the following 
MODIS band colors
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“Color” Rrs λ (nm)
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https://arset.gsfc.nasa.gov/
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Band Math (Math Bands)

1. In SeaDAS, double click on the Rrs image layers corresponding to 
the blue, green, and red bands in the CI algorithm

2. Apply land masks
3. Tile the images horizontally
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Band Math (Math Bands)

4. Access the Math Band tool either from the 
menu bar, Raster > Math Band, or from the 
toolbar with the math band icon: 

5. Click on it. It should show the combined file 
you just created. 

6. Give the new band you are about to 
create the name: CI

7. Use the Edit Expression tool to enter the 
Math Band expression
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Band Math (Math Bands)

• We advise you use the expression editor for the math band instead 
of tying the equations out in the Create Logical Expression (Math) 
Band window. 

8. Click OK to close the Expression Editor
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Band Math (Math Bands)

9. Click OK in the Create Logical Expression (Math) Band window to 
begin the process

10. When the new band appears, it is a virtual band. In the File 
Manager, right click on this new CI band and select Real Band.

11. The band should appear in the viewer. Give it a land mask and 
adjust the color manager so that you can view variability in the CI 
over the West Florida Shelf

12. Right click on the file (A2015051184000.L2_LAC_combined.dim) 
and select Save as…

13. Save it by the same name, overwriting the original
14. Close all image layers
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Statistics

1. Double click on the image layer named sst_D_R
2. Click on the pin manager  
3. Click on the create and add new pin icon      in 

the pin manager window
4. Name and label the new pin SuwanneeR_Mouth

and give it the following decimal degrees 
latitude and longitude: 29.29272, -83.18172
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Statistics

5. Navigate to the Mask Manager along the left 
pane of the viewer

6. Click on the Expression Editor function icon 
located within the Mask Manager

• We are going to create a mask that includes sea 
surface temperatures (SST) in the range of 9° C to 13°
C

• Note: Do not confuse this function icon with the 
other function icon on the main tool bar
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Statistics

7. Enter the expression you see below

8. Click OK
9. Rename this new region of interest mask as ROI_1
10. Change its color so the ROI has high contrast with the underlying 

image
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Statistics
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Statistics

11. Select the statistics tool on the toolbar.     This will open a window 
that at first will not have any statistics: 
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Statistics

12. You will need to make choices of what you would like to include in 
the statistics run. In this example, we will choose the bands:

– chlor_a
– SST
– adg_443_giop
– Kd_490

Collocate Bands

Band Math 

Statistics

Filter Band

Pixel Extraction

Combine 
(Mosaic) Two 
Images

https://arset.gsfc.nasa.gov/


NASA’s Applied Remote Sensing Training Program 23

Statistics

13. Click on Regional and leave the 
defaults as they are

14. Click on Quality and select the ROI_1 
mask you just created
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Statistics

15. Click on Criteria
16. Click on the Fields button and turn on Include Min/Max

17. Review the settings and click Run
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Statistics

• The output should automatically populate the statistics window
• Explore this window – scroll along the right to see both sets of figures
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Statistics

• These are the statistics for the full scene and the scene bounded by 
the ROI_1 mask 

• Because the ROI_1 mask is so large, the shapes of the figures are 
similar

• Look closely at the statistics output at the bottom in the statistics 
spreadsheet pane. Look for adg_443_giop and you will see the 
number of “Valid_pixels” for the full scene is greater than for the 
ROI_1 mask. The statistics for ROI_1 are being computed on a subset 
of the full scene.
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Statistics

• Remember, adg_443_giop is an estimate of light absorption by 
detrital matter (d) and colored dissolved organic matter (CDOM)

• The Suwannee River is a “blackwater river” and carries high 
concentrations of CDOM

• Before the river plume fully mixes with the surrounding waters and 
warms to their temperatures, this high adg_443 signature is notable 
and indicative of low salinity water
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Statistics

• Light absorption by CDOM can be used as a proxy for low salinity 
water in coastal systems

• Every river system has a unique CDOM-salinity signature
• It is important that if you are developing a CDOM-salinity algorithm 

that you create the algorithm using in situ measurements from the 
region of interest
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Statistics

18. Close the statistics window
19. We’ll use the scatterplot tool as a way to explore relationships 

between variables. Click on the Scatterplot Tool icon
20. The scatter plot window will open. Use the ROI mask Water_D, 

sst_D_R for the x-axis and adg_443_giop_D for the y-axis
21. Click on the Refresh View icon
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Statistics

• This plot shows a scatter plot for the 
entire water area, not just the masked 
area

• As temperature decreases, 
adg_443_giop increases

• This plot shows the relationship of 
temperature to light absorption by 
CDOM described in the previous 
section

22. Close the Scatter Plot window
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Filter Band

• The filter band creates a band by applying a convolution or non-
linear filter to an existing band

• This tool can be used to enhance features in an image
• SeaDAS has a number of filter options, as well as the option for user-

supplied filters
• Options for filters include functions to 

– smooth and blur the image
– adjust for stray light
– detect lines and gradients
– sharpen 
– enhance discontinuities
– apply a number of non-linear and morphological filters
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Filter Band

1. To use the tool, click Raster > Filtered Band to open 
the Create Filtered Band window

2. Below are some examples of filters applied to the 
KD_490 band. Try a few band filter methods to gain 
an understanding of how they modify the data

3. When finished, close all of the image windows
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Pixel Extraction

1. Double click on the chlor_a image layer
2. Using the pin tool, drop a pin into the scene
3. Launch the Pixel Extraction tool via Tools > Pixel Extraction

Collocate Bands

Band Math 

Statistics

Filter Band

Pixel Extraction

Combine 
(Mosaic) Two 
Images

https://arset.gsfc.nasa.gov/


NASA’s Applied Remote Sensing Training Program 34

Pixel Extraction

4. This will open a new window. On the Input/Output tab, update the 
entries for Output Directory
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Pixel Extraction

5. On the Parameters tab, 
change the window size to a 
3x3 pixel box

6. Choose a pixel value 
aggregation method as 
mean

7. De-select tie-points grids and 
masks

8. When satisfied with your 
choices, click Extract
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Pixel Extraction

• This produces an output text file, which you may 
wish to open using spreadsheet software

• This example only shows pixel extraction using a 
pin

• It is also possible to provide a table of 
coordinates for the extraction of multiple 
locations

9. Save and close the file
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Combine (Mosaic) Two Images

• We’ll demonstrate the last section with images from the Salish Sea 
region of northwest Washington State, U.S. and southwest British 
Columbia, Canada

• The files used in this section include:
– A2018136213000.L2_LAC_OC_SST.dim (and supporting .data file)
– A2018136213500.L2_LAC_OC_SST.dim (and supporting .data file)

• These are reprojected, collocated files of the region that include 
ocean color and sea surface 
temperature

• The region of interest is the greater Salish 
Sea, but one image did not capture the 
entire region. There is a need to mosaic 
two images together.
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Combine (Mosaic) Two Images

1. Find and click the Mosaic tool      on the 
toolbar

2. A window will open. Click the plus sign 
under Source Files and add the two 
collocated files

3. Enter a new name for the output file
4. Choose the directory path to the folder 

containing the original data for this scene
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Combine (Mosaic) Two Images

5. Click on the Map Projections Definitions 
tab

6. Edit the mosaic bounds to subset the 
mosaicked image to the region of interest

7. Click on the Variables & Conditions tab
8. Just below Variables, click on the Choose 

bands to process icon to open this window
9. Select all of the Rrs

bands, chlor_a, SST, 
Kd_490 and any other 
bands of interest

10. Return to the Variables & 
Conditions window
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Combine (Mosaic) Two Images

11. Under Variables, click on the plus sign and 
scroll to the bottom of the list of data 
products 

12. Name the new variable, LAND, and then 
click on the ellipses to the right of the 
Expression box

13. This will open the Expression Editor
14. Click the button next to Show single flags
15. Select l2_flags_R.LAND 
16. Click OK
17. Click Run
18. When it is completed, the new file will 

appear in the File Manager. Close the 
mosaic tool. 
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Combine (Mosaic) Two Images

19. If you click on the Layer Manager, it will be empty. We need to 
manually add the land mask to the file. On the left side of the 
viewer, click on the Mask Manager tab.

20. Click on the Create a new mask based on math icon
21. This will open the Create Logical Expression Mask
22. Scroll through the data sources to the LAND band and select it
23. Click OK
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Combine (Mosaic) Two Images

24. This will cause a new mask to appear in the Mask Manager. 
Double click on the name and change it to LAND

25. Double click on the color and change it to black
26. Double click on Transparency and change it to zero
27. Return to the File Manager and open chlor_a_R
28. Go to the Layer Manager and turn on the LAND mask by clicking 

the button next to it
29. Right click on the mosaic file in the File Manager and select Save 

As
30. Overwrite the existing file to preserve the land mask you just 

created
31. Close the original two files used to create the mosaicked file
32. Congratulations on creating a mosaic! 
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