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Objectives & Learning Outcomes

• To learn how to work with aquatic remote sensing imagery using NASA’s SeaDAS 
image processing software

• Learning Outcomes:
– Gain knowledge about aquatic remote sensing data products
– Gain knowledge in the processing of remote sensing imagery

https://arset.gsfc.nasa.gov/
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Additional Resources

• SeaDAS Introduction (2017): https://seadas.gsfc.nasa.gov/docs/SeaDAS_Intro.pdf
• SeaDAS Tools (2017): https://seadas.gsfc.nasa.gov/docs/SeaDAS_Tools.pdf
• An Exploratory Walk Through: 

https://seadas.gsfc.nasa.gov/docs/SeaDAS_Walk_Through.pdf
• SeaDAS Help Pages: https://seadas.gsfc.nasa.gov/help/

https://arset.gsfc.nasa.gov/
https://seadas.gsfc.nasa.gov/docs/SeaDAS_Intro.pdf
https://seadas.gsfc.nasa.gov/docs/SeaDAS_Tools.pdf
https://seadas.gsfc.nasa.gov/docs/SeaDAS_Walk_Through.pdf
https://seadas.gsfc.nasa.gov/help/
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Location of Study: Suwannee River Mouth, Florida, USA

https://arset.gsfc.nasa.gov/


Basic Functionality of SeaDAS



NASA’s Applied Remote Sensing Training Program 6

Data Download

• In the Part 1 Demonstration, you were provided with instructions on how to 
download the data for this exercise. You can also find the data on the course 
website. The Aqua-MODIS files used for this exercise are: 
– A2015051184000.L2_LAC_OC.nc
– A2015051184000.L2_LAC_IOP.nc
– A2015051184000.L2_LAC_SST.nc

• Save these files to a folder that is not too deep in the directory structure.

https://arset.gsfc.nasa.gov/
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Launch SeaDAS

• This is the default viewer
• Note that some of the screen shots 

shown in this exercise may not look 
exactly the same as what you see. This 
is okay. 

• The goal of the exercise is to be a 
roadmap for how to process imagery

• Some reasons for the mismatch could 
be from: 
– your computer’s operating system
– your version of SeaDAS 
– some user-defined layouts of the 

SeaDAS viewer

https://arset.gsfc.nasa.gov/
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Basic Functionality Skills in SeaDAS

• In this exercise you will learn:
– how to open a file
– how to choose rasters
– basic features of SeaDAS

• This document provides general directions on how to use SeaDAS. Note that not 
every step will be explained. As you master each skill, the instructions will assume 
more autonomy on your part.

• no data
• synchronizing
• create color bar
• export image

• land masks
• flags
• adjust color bar
• reproject

• zooming
• map location
• gridlines
• crop

https://arset.gsfc.nasa.gov/
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Opening a File

1. From the menu bar in SeaDAS, click on File > Open and 
a window will pop up

2. Navigate to the folder where you saved the images and 
click on the file named:

– A2015051184000.L2_LAC_OC.nc
3. Select the Open Product button. You will see the file 

appear in the File Manager pane of the SeaDAS viewer 
window. 

4. Using your mouse, adjust the width of this pane so you 
can see the full name of the file. Click on each of the 
three triangles next to Metadata, Flag Bit Coding, and 
Rasters to expand the view.

https://arset.gsfc.nasa.gov/
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Explore Some File Attributes

• Take some time and click on each of the attributes under the Metadata and Flag 
Bit Coding folders

• Windows will pop up as you look through these to provide information such as the 
attributes of the satellite overpass and sensor, the location and time, the ambient 
sun angle and atmospheric optical properties, units for the observations, etc.

• For the purposes of this exercise, we will not be going into great detail about the 
values in the Metadata

• As you become more proficient in image processing it is a good idea to refer to 
these files to better understand the conditions under which the imagery were 
collected and if an processing errors were encountered

• Close all of the windows that opened when you were reviewing Metadata and 
Flag Bit Coding

• Collapse those folders by clicking on the triangle to the left of the folder name

https://arset.gsfc.nasa.gov/
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Choosing a Raster
• When exploring imagery on a server like NASA’s Worldview, easy 

to view imagery includes chlorophyll-a and Sea Surface 
Temperature (SST). The individual data files that you can 
download from the Level 1 & 2 Browser includes much more than 
just chlorophyll-a and SST

• Look at the raster choices in the File Manager. The data products 
include:
– Remote Sensing Reflectance at 10 wavelengths (Rrs)
– chlorophyll-a (chlor_a)
– diffuse attenuation of light at wavelength 490 nm – a proxy for particles (Kd_490)
– particulate inorganic carbon (pic)
– particulate organic carbon (poc)
– instantaneous photosynthetically active radiation, or light from 400 – 700 nm (ipar)
– normalized fluorescence line height – a proxy for phytoplankton biomass measured in a 

different part of the spectrum than chlor_a (nflh)
– l2_flags
– Location data

https://arset.gsfc.nasa.gov/
https://worldview.earthdata.nasa.gov/
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Choosing a Raster

5. Double click on chlor_a in the 
A2015051184000.L2_LAC_OC.nc file

– Note that the SST data are missing 
from this file

– Recall that this file has ‘OC’ 
appended to it to indicate ‘ocean 
color’

– We also want to view the SST image. 

https://arset.gsfc.nasa.gov/
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View the SST Image

6. Following the instructions from Step 1, 
open the file named: 
A2015051184000.L2_LAC_SST.nc

7. Double click on SST under rasters in the 
A2015051184000.L2_LAC_SST.nc file

– We want to observe the Suwanee 
River Plume

– The river is a naturally occurring 
“blackwater river,” which means it 
has high concentrations of colored 
dissolved organic matter (CDOM) in it

– To observe CDOM, we want to use 
the data product named 
adg_443_giop

https://arset.gsfc.nasa.gov/
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Observe CDOM

• adg_443_giop is an estimate of the 
absorption coefficient of non-algal 
material plus CDOM (adg ) at 443 nm 
in m-1

– Remember that absorption is an 
inherent optical property (IOP)

8. Follow the same file open instructions 
and open the file named: 
A2015051184000.L2_LAC_IOP.nc

9. Double click on the adg_443_giop
raster in the 
A2015051184000.L2_LAC_IOP.nc file

https://arset.gsfc.nasa.gov/
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Compare Chlorophyll, SST, and CDOM

10. Click on the chlor_a tab in the main viewing window
– Take some time now using your mouse to move the image around and to 

practice using the selection, panning, and zooming tools:
11. Try zooming into the Suwannee, FL area

– Observe the features offshore
– Think about what these colors mean
– Note that this image has not yet been reprojected. We will get to that later. For 

now, we will try using some of the basic tools of SeaDAS.

https://arset.gsfc.nasa.gov/
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No Data

1. Click on the No Data icon      in the tool bar
– This action will grey-out no-data values in the layer 

2. Resize the pane on the right so you can read the information in the 
Pixel Info pane

3. Using your mouse, roll over the areas where there are no data and 
where there is data

4. Look at the values for chlor_a and see how they change between 
no data and data regions of the image

No Data

Land Masks

Zooming

Synchronizing

Map Location

Flags (and Pins)

Adjust Color Bar

Create Color Bar

Gridlines

Export Image

Reproject

Crop

https://arset.gsfc.nasa.gov/
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No Data
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https://arset.gsfc.nasa.gov/
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No Data

5. Note the chlor_a values in the Pixel Info window
6. My mouse (not visible on slide 18) was hovering over an area to 

the west of Tampa, FL. Chlor_a had a value of 0.38838354
7. Repeat the No Data step with the SST and adg_443_giop images 

on your own time
8. Save your session by clicking on File > Session Save
9. Navigate to the folder where the data file is located 
10. Name the session SuwaneeR.seadas and select Save
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https://arset.gsfc.nasa.gov/
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Apply a Land Mask

1. Look at the tabs on the bottom of the File Manager
pane. Click on the tab named Mask.

2. Click on the box next to the mask named Land.
– Toggle it on and off. What do you think this mask 

is? Turn off CLDICE.
3. Change the Land mask color to black by double-

clicking on the colored box for that mask choice. 
Adjust the color of the mask.

4. Repeat with SST and adg_443_giop on your own 
time.

No Data

Land Masks

Zooming

Synchronizing

Map Location

Flags (and Pins)

Adjust Color Bar

Create Color Bar

Gridlines

Export Image

Reproject

Crop

https://arset.gsfc.nasa.gov/
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Apply a Land Mask
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https://arset.gsfc.nasa.gov/


NASA’s Applied Remote Sensing Training Program 22

Apply a Land Mask

5. Save your session by clicking on File > Save As
6. Navigate to the data folder. You will be 

asked if you wish to save as BEAM-DIMAP 
format. Click Yes. 

7. Click on each tab in the viewer and 
repeat these save instructions for SST and adg_443_giop on your 
own time

8. Save the file as the default: 
– A2015051184000.L2_LAC_OC.dim
– A2015051184000.L2_LAC_SST.dim
– A2015051184000.L2_LAC_IOP.dim.  

9. Take a moment and save the session to SuwaneeR.seadas using 
the previous instructions
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https://arset.gsfc.nasa.gov/
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Zooming with Navigation

1. Look at the lower right pane of the window, named Navigation 
Controls

2. Take some time now to zoom in and zoom out with these 
controllers in each of the three open tabs

3. Hover your mouse over each of the magnifying glasses to see a 
description of the tool in the tool tip

4. Zoom all
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https://arset.gsfc.nasa.gov/
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Synchronize

1. Go to the menu bar to Window > Tile Horizontally
2. Click on the chlor_a window and Zoom All

– Note that the zoom did not change for the SST window
– Often, when we explore multiple image files, we wish to 

synchronize the controllers
3. To synchronize the two layers we’re observing, click on the 

synchronize tool in the Navigation Controls window
• Now, when you pan or zoom in one window, both windows will be 

synchronized. When you are finished, click off the synchronize tool
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https://arset.gsfc.nasa.gov/
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Map Location

1. Drag the World Map Location pane out of the window, resize it, 
and click on the zoom button in the upper right corner

– This will show you where the image swatch is in the world
2. Right click the upper part of the window and de-select Floating to 

return it to the viewer
3. Click zoom in the World Map Location pane
4. Close the World Map Location pane to make more room available
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https://arset.gsfc.nasa.gov/
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Flags (and Pins)

1. Below the Rasters pane, click on the Flags icon       
This will open the Flags pane.

2. Close the Navigation Controls pane
3. In the Pixel Info Pane, close the Geo-location and 

Rasters sections by clicking on the X at the right of 
the pane

4. Run the mouse of the scene. “Invalid pos.” remains 
consistent across the list of flags: 
https://oceancolor.gsfc.nasa.gov/atbd/ocl2flags/

5. Click on the pin tool
6. Find a spot just ocean-ward of the mouth of the 

Suwannee River
7. Click on the spot while the pin tool is active. You 

might need to zoom in a little.
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https://arset.gsfc.nasa.gov/
https://oceancolor.gsfc.nasa.gov/atbd/ocl2flags/
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Flags (and Pins)

8. Look towards land from this position and you will see the grey pixels 
characteristic of “no data.” Put a pin into that gray location

9. Switch from the pin tool to the selection tool (the arrow)
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https://arset.gsfc.nasa.gov/
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Flags (and Pins)

10. Take turns clicking near the tip of each pin and observe how the 
Flags information changes. 

– Which flags are present at the tip of Pin 2? 
11. Next, click on the pin manager tool      This will open the following 

window

12. Click on each row to highlight it, and then click on the garbage 
can icon to the right of the window to delete it. 

13. Remove all pins this way, and then close the pin manager
14. Click on View > Reset to Default Layout to return the viewer to the 

default pane setup
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

1. Click on the chlor_a window
2. On the lower, left side of the viewer, click on the 

Color Manager tab
3. The Basic button is already selected. Under Scheme, 

click on Scheme Selector
4. Look at the available options. Choose the Chl

(UniBr-Palette), which will load the Cpd File 
universal_bluered.cpd

5. Look at the top of the Color Manager panel and 
click on the Sliders button
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

6. There is a lot of functionality in this pane. For our 
purposes, we are going to adjust the color by 
choosing a spread of 95% instead of 100%.

7. Click on the icon along the upper right of the color 
manager named 95%
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

• Note the difference in the histogram views before and after 
adjusting the spread of the color bar across the data

• What do you think this setting just did? 
• Why do you think we would want to make such an adjustment? 
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

8. Take some time to make adjustments to the spread, Log10, and 
Histogram matching. Observe how it changes the display of the 
imagery.

9. When you are finished, return the settings to Log10=on (looks dark), 
100%, and Histogram matching=none

10. Click the button next to Basic at the top of the Color Manager 
pane and try changing the CPD File to change the color palette 
to one of the many options. Explore different  palettes.

11. When you are finished, return to the universal_bluered.cpd
palette. This is a color blindness compliant palette. Read more on 
this palette in SeaDAS »

12. To adjust the color range in the Color Manager pane, click on Set 
from Band Data
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https://arset.gsfc.nasa.gov/
https://seadas.gsfc.nasa.gov/help/color-blind-config/ColorBlindConfig.html
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Adjusting the Color Bar

13. Look at the image. Zoom in if you need to see features more 
clearly.

14. In the Pixel Info pane on the right, click on the Show/Hide Rasters
icon      so that you can see information about the image as you 
pan your mouse over the scene

15. Close the Flags pane if it is still open
16. Pan your mouse over the scene making sure to look at regions of 

low values (blue in this palette) and high values.
– If you are not seeing values, be sure to turn off Snap to selected 

pin
17. Return to the Color Manager pane
18. Click on Set from Band Data
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

19. Double click the Max: cell, type 15, and hit return. What happens?
20. Try setting the minimum and maximum manually

– There appears to be a bug in SeaDAS here
21. If you find no change, re-hit Set from Band Data and try again.

– What range makes sense to you? 
A given region tends to have typical chlorophyll concentrations 
during non-bloom periods. The West Florida Shelf has a median 
chlorophyll concentration of 0.26 μg/L (or mg/m3), and a range of 0.2 
to 13.3 mg/L. 
With this in mind, try choosing a narrower chlorophyll range than what 
is being suggested from the full range of the band data. Do this to get 
a more sensible dynamic range. Note: the display is showing a log-
scale as the default.
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

22. Repeat setting the palette and ranges for the SST and 
adg_443_giop data products on your own time. For SST use color 
bar Scheme > SST. For adg_443_giop choose the same scheme as 
the one used for chlorophyll

23. Use your judgement and the Pixel Info data as you move your 
mouse over the image to choose a meaningful Min/Max range for 
SST and adg_443_giop
Important note: your
images will not match 
exactly to these because 
your Min/Max choices 
will differ.

24. Click on Window > 
Tile Horizontally
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https://arset.gsfc.nasa.gov/
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Adjusting the Color Bar

25. Tidy up your viewer by synchronizing your windows and adjusting 
the pane size so you can maximize viewing the imagery

26. Save the session
27. Look at the adg_433_giop pane. 

– What do you think is going on at the mouth of the Suwannee 
River? 

– What does the L2 flag say for this? 
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https://arset.gsfc.nasa.gov/
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Create a Color Bar

1. Click on the chlor_a window so that it is the active layer
2. Look along the tool bar. Find and click the color bar tool 

3. Click on Create Layer
4. Zoom all     to see the color bar
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https://arset.gsfc.nasa.gov/
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Create a Color Bar

5. The image has a color bar, but it is small and hard to see
6. Click on the color bar tool again. This time, change the following 

settings: Title > chlor_a, Units > (mg m^-3), Size Scaling > 90.0, 
Location > Outside Image, Location & Alignment > Bottom Center 
to put the color bar outside the image. Leave other settings alone.
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https://arset.gsfc.nasa.gov/
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Create a Color Bar

7. Click on the preview to see it is what you want. 
When you are satisfied, click on Create Layer. Your 
output should look like the image on the right.

8. Repeat the steps to make a color bar for your SST 
and adg_443_giop images on your own time. Be 
sure to use the appropriate Title and Units for those 
data products: SST (degrees C), adg (m^-1).
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https://arset.gsfc.nasa.gov/
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Create a Color Bar

1. Click on the chlor_a pane and re-size it so that you can see the 
entire image

2. Look along the tool bar and find the gridlines tool and click it: 
3. Look at your scene. This tool adds the gridlines to your image. 
4. Look closely at the bottom part of the scene near the color bar. 

The notation for the coordinates at the bottom is running into the 
color bar.

5. It is possible to remedy this. Verify that the gridline tool is the active 
tool, then click on the Edit Layers Properties tool: 
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Create a Color Bar

6. The window below will open. Click Show Longitude Labels – South 
to remove the longitude labels so they will no longer be in conflict 
with the color bar

7. Close the window after you make the change
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Create a Color Bar

• Note that the labels along the bottom of the image are gone
• As long as the gridlines are active, you can return to the Edit Layers

tool to make changes to the format of the gridlines
• These changes will be preserved when you export the image to an 

image file
8. Repeat this gridlines step with the SST and adg_443_giop images 

on your own time
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Export Image

1. Now you have an image with a color bar and gridlines. Zoom all 
for all images

2. Resize the image windows so that you can see just the area you 
would like to export

3. Make sure the gridline labels are visible in the window
4. Right click on the image 

you want to export and 
click on Export Image

5. This will open a window
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Export Image

6. You could choose to just save the image with the default settings, 
but that is going to give you an image with coarse resolution

7. Instead, it would be a good idea to adjust the width and height of 
the image size

8. Save it with the file name and “_image” appended to the name, 
like the example below: 
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Export Image

9. Repeat these steps for SST and adg_443_giop images on your own 
time

• If you are not satisfied with the output, change the gridline, color 
bar, or export options to arrive at an image you like

10. Make sure to Save As a new file name for the different examples 
you produce, unless you want to overwrite your earlier attempts
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Reproject

• Congratulations on getting this far! The images you produced in the 
previous section are not projected the way we need, so we will re-
project them and export new images

1. Close the SST and adg_443_giop files
2. Click on the chlor_a pane to make it the active layer
3. Click on the map projection tool
4. This will open the Create Reprojected File window. Use the images 

on the next slide to change the tabs in this window to match. Be 
sure the directory path you enter matches the correct path for the 
system you are using.
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Reproject
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Reproject

7. Use the bilinear resampling method
8. Click Run when you are satisfied with your settings
9. When the process is complete, click Close
10. These settings will automatically save the new, reprojected file and 

open it in SeaDAS. 
11. If you want to see how the projection works, without saving, be 

sure to click off the Save file as button on the I/O Parameters tab 
of this window

12. When the process is complete, open the chlor_a layer of the newly 
reprojected file

13. Close the previous file 
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Reproject
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Crop

• The image of the reprojected chlorophyll a layer illustrates the need 
to crop the image to the region of interest

• There are a number of methods to crop using SeaDAS. The method 
here is the simplest and most straightforward

1. Open the cropping tool from the tool bar
2. This will open the Create Cropped File window
3. Stay in the Spatial Subset setting
4. If you know the geographic coordinates for the region of interest, 

click on the button labeled Geo Coordinates and enter your 
coordinates

5. If you are not sure, click on the Pixel Coordinates button and set 
the boundaries manually by adjusting the rectangular region in the 
pane on the left of the cropping window
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Crop

6. When you are satisfied with your bounding box, return to Geo 
Coordinates and write down all of the latitude and longitude 
values for the bounding box

7. Leave all of the other settings on default
8. Click OK
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Crop

9. This creates a new file that is visible in the File Manager. Note the 
odd color next to the layers icon at the file name (it looks like a 
stack of pancakes). This tells us the file needs to be saved. 

10. Take a moment to open a raster and observe if the cropping was 
done to your preference.

11. Right click and choose Save As
12. A new window will appear with a default file name. Change the 

name so that you don’t accidentally overwrite the original file
13. Name it A2015051184000.L2_LAC_OC_reprojected_subset.dim and 

click Save 
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Crop
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Crop

14. Take a moment to close some of the files you have open in the File 
Manager. 

15. It is up to you whether you want to save any changes made to the 
file

16. The newly cropped file should be the only file still in the File 
Manager

17. Repeat the steps for adjust color, color bar, gridlines, and export to 
produce a new, exported image of this reprojected and cropped 
region

18. When you are finished, save the session and close SeaDAS
19. On your own time, repeat these steps for the SST an adg_443_giop 

images. Note: Be sure to use the exact same geographic 
coordinates used for chlor_a when cropping these other files.
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