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Objective

* Learn to use SeaDAS to analyze MODIS Level-2 Ocean Color data and images
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Open MODIS Level-2 Files in SeaDAS

1. Open SeaDAS GUI on your computer Blank SeaDAS GUI when opened

2. Locate the MODIS Chlorophylldata [ © = o o, 0 ™ it aeoe s
file that was saved from the Ocean AL
Color Web in Exercise 1 for Lake
Victoria
(A2018024112500.L.2 LAC OC.nc)

3. Explore the options on by moving the
computer cursor on each option

O OO  Pixel Info
@ Geo-location

4. On the top bar click on File > Open

ZI:B Edit View Layer Vector Raster OCSSW Tools Analysis Window Help

Open ... ~0 RN
' @ Open Recent > - ) SeaDAS 7.5.1 )
A Open Utilities » @g ‘@HQO\):‘“ ao\ é .+
Session Open...
Import »
Export > i—ilgm.. | Zm. |Bc.|
Export Other >
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https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/A2018024112500.L2_LAC_OC.nc

Open MODIS Level-2 Files in SeaDAS

5. Navigate to the MODIS OC file on
your computer

6. Click on the flename - you will see e

the file and data information in the 7/~ EETEEGEmmS &

» || Flag Bit Coding

File Manager window on the left e

@ O] Open Data Product(s)

File: AZ2018216112500.L2_LAC_OC.nc

|5 Desktop B
Name ~  Date Modified
= 05022018_prorobloom.gif Saturday, August 11, 2018 1:06 AM
a 2018_07_27.pdf Tuesday, August 14, 2018 2:59 PM
» 2018_08_10.pdf Tuesday, August 14, 2018 2:58 PM
= Ajpg Thursday, September 14, 2017 11:13 PM
* A20182 16112500.L2_LAC_IOP.nc Saturday, August 11, 2018 8:49 PM
B A20182161 12500.12_LAC_OC.nc Saturday, August 11, 2018 8:51 PM
“ A20182 16112500.L2 _LAC_S5T.nc Saturday, August 11, 2018 8:50 PM
[ AOI_NASA_PROPOSAL Tuesday, June 12, 2018 1:32 PM
[ ARSET-2018 Friday, August 10, 2018 12:21 PM
[ avMm Monday, August 13, 2018 12:35 PM
File Format: | All Files B

New Folder Cancel _
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Open MODIS Level-2 Files in SeaDAS

7. Click on Rasters to see the available
Level-2 data

[ ] [ ] [1] chlor_a - [{Users/amitamehta/Desktop/A2018216112500.L2_LAC_OC.nc] - [Session not saved] - SeaDAS 7.5.1
aEBO AP FEQHO @Y rEIA Bmowm\ O i iZh
O O O File Manager _[1]chl-nr_a b4

v = (1] A2018216112500.12_
» [ Metadata ece @ [1] chlor_a

Flag Bit Coding

8. Point your computer cursor on each

parameter to read a brief description . 2@
B ;|

[ chl_ocx

9. Click on Chlor_a in the list = “E

10. You will get the Chlorophyll image in 2o Ny
the SeaDAS main window e — g

Rasters

il Zla. [ Zum. B c. |
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Add Masks and a Color Table

11. On the bottom of the left-hand window, click on the Manage binary
data masks and ROI

) ) ) Mask Manager - [1)
@ Name Color

LAND !

|: ABSAER Iz

ATMFAIL :

ATMWARN /e

g Fil.. |§ La.. |£ M.. | L:'. C. BOWTIEDEL (g
CHLFAIL B :

CHLWARN (R!

CLDICE [ ]2

COASTZ !

COCCOLTH o

12. You will see the masks option in the left window > Cam

HIGLINT R
HILT [z
HIPOL !
HISATZEN R!
HISOLZEN B
LOWLW o
MAXAERITER [ 1
MODGLINT R
NAVFAIL B :
NAVWARN /e
PRODFAIL iz
PRODWARN N
SEAICE [z
sTRAYLIGHT [ @
TURBIDW |
Quality_L2 | |
Quality_L3 o
Water o
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Add Masks

13. Select the land mask by clicking the

LAND box AE—
— The land mask will be added to the . =:2:c
chlor_a image with the default D_
color B
— You can click on the color boxand | " %%
pick other colors from the drop- o,
down menu el
14. Next, select the CLDICE mask and o (2
change the color to see the e ¢ 3
locations where data are missing G '# b1
because of clouds — o ’ B
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Change the Color Table

15. Select the color palette of band oo
) © Basic Sliders Table e0e [H [1] chlor_a
Image .
— You will see the color options p chomessecer B
e lla‘.—""-l Eiga;i:)lor standard.cpd
= File.. |Z Laye. |2 Mask. ME-Golos ?cpdﬁ.eem:uesd :
Reverse Save ;ﬁ}t :
16. Under Range, change the min value &= Sy
to 0.1 and the max value to 60 |
. . Set from Band Data l#
— You will see the chlor_a image /
changing colors
17. You can select another color palette ....... £
from the drop-down menu under e O )
Cpd File > Oceancolor_Standard.cpd e @ A
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Add a Color Bar

18. From the top menu, select View
and/or Export the color bar

s EEs Newe AW E

19. You will get a Create/Edit Color Bar =
window

— keep the default options for now -

you can explore the options at your
convenience

20. Click on the Create Layer option on
the bottom right of the window

.........

13 EEgfen
TR PO
- "Rk
1) 1188,
s EEEES &
- PIT
5 g

21. Click on Show/Hide map gridlines
layer

SEE R FH@E
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Image W|th the color bar and grid Ilnes
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Zoom in and Examine Chlor_a Values

22.Z00m in on Lake Victoria by using the
Navigation Controls window on the
right
— Or use the top menu to zoom and
pan the image

OO0  PixelInfo
& Geo-location
Image-X 696 pixel
Image-Y 714 pixel
Longitude 32°14'4... degree
Latitude 1°07'38... degree

23. Move the cursor onto the image and
examine the Rasters window on the
right to see longitude, latitude, and
corresponding chlorophyll values

[E Rasters

chlor_a  31.37337 mg m~-3

B longitude 32.244... degrees...
latitude  -1.127... degrees...
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Save the File and the Session

24. To save the session, first the data file has to be saved In
a BEAM-DIMAP format

25. Right click on the file name in the File Manager Window
and click Save As

26. You will be asked to convert the file into the dimap
format

In order to save the product
[1] A2018216112500.L.2_LAC_OC.nc
ﬂ it has to be converted to the BEAM-DIMAP format.
\ Depending on the product size the conversion also may take a while.

o you really want to convert the product now?

27. Click Yes and save the file on your computer

28. Go to File > Session Save and follow the steps to enter a B
name for the session, ending in .seadas, and click Save penuties »
29. You can open this session later by using File > Session *
Open — e —
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Crop the Raster Layer

30. Zoom in on Lake Victoria so that the
main SeaDAS window covers only
the lake

31. On the top menu, go to Raster >
Crop

32. You will see a window showing the
zoomed-in region available to be
cropped

33. Select OK and you will get the
cropped raster as a new layer
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B ocssw
DEM Band ...
Filtered Band...
Math Band...
Real Band

Collocate...

Flip Data...
Image Analysis
Level-3 Binning
Mosaic...
Orthorectify...
Reproject...
Time Series

Tool:

[ [1] chlor. a

aaaaa




Display the Cropped Chlor_a Layer

34. You will see the new, cropped raster
layer in the File Manager window

35. Click on Chlor_a to add the cropped
raster layer

v = [1] A2018216112500.L:
» [ Metadata
» [ Flag Bit Coding
» [ Vectors
v E Rasters
» [ aot
[ angstrom
» [ Rrs
B chlor_a
[ chl_oex
» [ Kd
[ pic

36. On the top menu, go to Window >
Tile Horizontally to see both the
original and cropped chlor_a layers - «ommmem

37.Zoom in on both layers to make sure m
that the cropped layer only covers 0 e
Lake Victoria e

NASA’s Applied Remote Sensing Training Program



Calculate Statistics

38. Select the cropped chlor_a layer by
clicking on the window

39. From the top menu bar, select
Display Statistics for selected band(s)

GO et s 1

— A window titled Statistics -
[2]chlor_a will open

40. Select Run to get statistics of chlor_a
for Lake Victoria on August 4, 2018
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chlor_a
Regional_Pixels
Valid_Pixels
Fraction_Valid
Mean
Standard_Deviation
Variance
Coefficient_of_Variation
Total_Bins
Bin_Width

Bin_Min

Bin_Max
80%Threshold
85%Threshold
90%Threshold
95%Threshold
98%Threshold

Statistics Spreadsheet

Statistics - [2] chlor_a

[ —

File# Band Regional_Mask Quality_

2 chlor_a

158004 QiU Regional  Quality  Criteria
41873
0.2650 and Searc
14.7395 —_—
17.5306 aot_869
iul?é;iza angstrom
1000 Rrs_412
0.0980 Rrs_443
1.8009 Rrs_469
49.7924 Rrs_488
27.8667 o e
34.0402 Select All Select None
41.5856
51.7768
63.8298
Run Reset

»




Plot Histogram

41. Make sure that you are working with
the cropped layer

— Note: you may remove the original
chlor_a layer by clicking on the ‘x’

[1]) chlor_a | [2]) chlor_a :=-=:|

42. From the top menu bar, select
Display Histogram for a selected

band
() 1 s 1

— A window titled Histogram - [2]
chlor_a will open

43. Select X-Axis > Log 10 scaled

44. You will see a histogram in the
window
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Histogram - [2] chlor_a

Histogram for chlor_a

100

ol

Use ROl mask:

L=
£z

#Bins: 512
Logl0 scaled bins

Log10 scaled

HFXes @

ooo o)
mom oo

oo
TR 3

- H

mn
'
b
i




Analysis and Visualization of MODIS Band Reflectance

45. Click on the cropped
layer file name and
select RGB Image

] lattude

7

v &
| Metadata
» | 7| Flag Bit Coding
¥ | Rasters
k| |aot
[ angstrom
| |Rrs
(71 chlor_a

Close ~W

Save af...

DEM Bgnd ...

New (Rometry Container...

46. Click OK to get a true
color RGB image

[ N ) " Create RGB Image
Profile:
NASA MODIS L2

Red: Rrs_667
Green: Rrs_531

Blue:  Rrs_443

| Store RGB channels as virtual bands in current product

"_ﬁﬁ

[ chl_ocx
= B Kd
[ pic
[ poc
[ ipar
[ nflh
[ par
[ 12_flags

RGB Image...

;;;;;;
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Cancel

Help

s L2 x W

[E [2] NASA MODIS L2 (2)

RGB Image



Synchronize Images

47. On the top menu bar, select Window
> Tile Horizontally

48. You will see the chlor_a and RGB
Images

49. Go to the Navigation Control window
(bottom right) and click on the
Synchronization Tool

Rrs_443 Invalid ... srA-1

Rrs_531 Invalid ... srA-1

Rrs_667 Invalid ... srA-1

chlor_a Invalid ... mg m#...
tude Invali i

EES ¢ ®

| Snap to selected pin

O O O Navigation Contro Is

50. Now when you pan and move an
Image in one window, the other
window will move along with it

Synchronise window views of compatible bands fproducts
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Calculate MODIS Band Ratios

51 GO to Raster > Math Band @ @ Create Logical Expression (Math) Band
) i Target file:
— awindow will open [1] A2018216112500.L2_LAC_OC a
— make sure the Target File is the — Name. > :
: gBandRatio

MODIS OC file

52. Enter LogBandRatio (or name of your
choice) in Name: for a new raster
name

Description:

! Unit:
I Spectral wavelength: 0.0

Virtual (save expression only, don't store data)

53. Click on Edit EXpreSSiOn Replace NaN and infinity results by MaN
\ Math Band expression:
\ Edit Expression...

“ Cancel Help

T —
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Calculate MODIS Band Ratios

. . . LN Expression Editor
54. You will get an Expression Editor e et
window sngatron EX
55. Click on Functions and click log10(@) =
from the dropdown selections. P T
56. Now highlight @ in the expression Gstowbanss | comns. B
Shnw maSks U]'.IE':'-EI.L'.DEE. " e
57. Enter the band ratio S e -
. ow single flags
log10(Rrs_443)/(Rrs_555) using the ot
acos ()
Data Sources on the left and the ==zl(0.4)
operation @/@ in the middle window

cail(l)

58. Click OK
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Calculate MODIS Band Ratios

888 File Manager 1) chlor_a X | [1} LogBandRatio

59. You will get back to the Create
Logical Expression (Math) Band Y

|71 Flag Bit Coding

- ¥ [ Vectors
Window 2o

= ground_contro |_points

B text_annotations
R ¥ [ Rasters
60. Click OK
L] gstrom
>

61. You will get the image of the %
Logl10O(Rrs_443/Rrs555)

62. Move the cursor to examine the épf}';;ﬂ}
values of the band ratio e

y
= File.. | = Luvc..‘ 2 Mas.. | @ col. | I
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To Derive Your Own Algorithm

* You need in situ measurements of chlorophyll concentration in the lake

* You will compile the above ratio in a number of MODIS images over the lake using
OceanColor Web

 Average the MODIS band ratios around the in situ measurement point, for
example: use 3 to 5 pixels square centered at the in situ data location for each
day

* Derive the statistical relationship between the in situ and the MODIS-based data

Note: The OC Chlor_a algorithm is a 4t
order polynomial in Log10(Rrs_443/Rrs555)
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OPTIONAL: Examine Surface Band Reflectances (R,,)

[ latitude

1. Inthe File Manager, in the layer cropped to Lake Victoria, & [2] A2018216112500.L2

Click on Rrs to see various band reflectance layers ETE“B':'_“; y
ag Bit Coding

2. Click on the layers and examine features in corresponding Rasters
. aot
Images [E angstrom

3. You may want to repeat the analysis you did for the chlor_a F*D”R 12 412
. . . Fs_ I
(.,e. change colors, calculate statistics) B Rrs_443 (443 |

] Rrs_469 (469 |
] Rrs_488 (488 |
B Rrs_531 (531
] Rrs_547 (547 1
] Rrs_555 (555 |
[F] Rrs_b645 (645 |
B Rrs_667 (667 |
] Rrs 678 (678 |

Mehior «
=
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Homework Questions

Complete the google form available at
https://arset.qsfc.nasa.gov/water/webinars/wqg-imaqge-processing

1. What are the units of MODIS chlorophyll concentration?
2. Which bands are used to make RGB images?

3. Based on the statistics for Lake Victoria, what was the mean and standard
deviation for chlorophyll concentration?

4. How many distinct peaks can you see on the histogram?
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https://arset.gsfc.nasa.gov/water/webinars/wq-image-processing

Thank You
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