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Ejercicio 2-a: Analizar la Concentracion de Clorofila
Nivel-2 e Imagenes de MODIS

Amita Mehta

12 de Septiembre de 2018




Objetivo

« Aprender a utilizar SeaDAS para analizar imagenes y datos MODIS Nivel-2 del
Color Oceanico
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Abrir un Archivo MODIS Nivel-2 en SeaDAS

1. Abra SeaDAS GUI en su computadora SeaDAS GUI en blanco cuando se

2. Ubique el archivo de datos de clorofila abre

segun MODIS que guardd de OceanCoIlor L gisime 21 i00 ot L oa Baoe .
Web en el Ejercicio 1 para el lago Victoria
(A2018024112500.L.2_ LAC_OC.nc)

3. Explore las opciones moviendo el cursor
de la computadora sobre cada opcion

4. En la barra superior haga clic en File >

seadas SeaDAS WFlEM Edit View Layer Vector Raster OCSSW Tools Analysis Window Help
Open ... Eell Open a data file. ma
@ Open Recent > L SeaDAS 751

5 :  Open Utilties > ®ﬁi@$@°\$ﬁk Q&&I,f

g S o [ S 2|

v

Import
Export

v

Export Other >
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https://oceandata.sci.gsfc.nasa.gov/cgi/getfile/A2018024112500.L2_LAC_OC.nc

Abrir un Archivo MODIS Nivel-2 en SeaDAS

5. Navegue al archivo MODIS OC en su
computadora

6. Haga clic en el nombre del archivo —
vera el archivo y datos informaticos en la
ventanilla de SeaDAS a mano izquierere

@ O] Open Data Product(s)

) @ ) File Manager
(1] A2018216112500..2_[[ NN
|7 Metadata

|71 Flag Bit Coding
| | Rasters

v v v

File: AZ2018216112500.L2_LAC_OC.nc

|51 Desktop B
Name ~  Date Modified
= 05022018_prorobloom.gif Saturday, August 11, 2018 1:06 AM
a 2018_07_27.pdf Tuesday, August 14, 2018 2:59 PM
» 2018_08_10.pdf Tuesday, August 14, 2018 2:58 PM
= Ajpg Thursday, September 14, 2017 11:13 PM
* A20182 16112500.L2_LAC_IOP.nc Saturday, August 11, 2018 8:49 PM
B A20182161 12500.12_LAC_OC.nc Saturday, August 11, 2018 8:51 PM
“ A20182 16112500.L2 _LAC_S5T.nc Saturday, August 11, 2018 8:50 PM
[ AOI_NASA_PROPOSAL Tuesday, June 12, 2018 1:32 PM
|| ARSET-2018 Friday, August 10, 2018 12:21 PM
[ avMm Monday, August 13, 2018 12:35 PM
File Format: | All Files B

New Folder Cancel _
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Abrir un Archivo MODIS Nivel-2 en SeaDAS

7. Haga clic en Rasters para ver los

[ ] [ ] [1] chlor_a - [{Users/amitamehta/Desktop/A2018216112500.L2_LAC_OC.nc] - [Session not saved] - SeaDAS 7.5.1
dat Ni -2 di ib| giHBEO NP FEAH O Y A Snow\ O 0L T
a OS IVe = Isponl eS @ O O File Manager
v = [1] A2018216112500.L2_]|

3 Metadata ede @ [1] chlor_a

> Flag Bit Coding
Rasters

8. Apunte el cursor de su computadora

a cada parametro para leer una T
breve descripcion B

[ pic
[ poc

9. Haga clic en Chlor_a en la lista S
glp;‘_rﬂags === ﬁ’

10. Le saldra la imagen de la clorofila en S 4
la ventanilla principal de SeaDAS |

il Zla. [ Zum. B c. |
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Agregar Mascaras y la Tabla Cromatica

11. En la ventanilla izquierda al fondo haga clic en Manage binary data
masks and ROI

™ 0 ) Mask Manager - [1]

@ Name
LAND

l: ABSAER
ATMFAIL

ATMWARN
g Fil.. |§ La.. |£ M.. | L:'. C. BOWTIEDEL
CHLFAIL
CHLWARN
CLDICE
COASTZ
Ve . Ve . . . COCCOLITH
12. Vera la opcion para mascaras en la ventanilla izquierda >
HILT
HIPOL
HISATZEN
HISOLZEN
LOWLW
MAXAERITER
MODGLINT
MNAVFAIL
NAVWARN
PRODFAIL
PRODWARN
SEAICE
STRAYLIGHT
TUREIDW
Quality_L2
Quality_L3
Water
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Agregar Mascaras

13. Seleccione la mascara terrestre

haciendo clic en la casilla LAND i s
— La mascara terrestre sera Sy mEEEEEEE
agregada alaimagende clor_a & e
con los colores preprogramados | oy Ef};_
— Usted puede hacer clic en el - %%
cuadro de colores y elegir otros o
colores del menu desplegable oo @:%
14. Ahora seleccione la mascara CLDICE | row =i
y cambie el color para ver las e ¢ ;
ubicaciones donde falta datos por G '# V)
causa de las nubes — o ’ B
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Cambiar la Tabla Cromatica

15. Seleccione color palate of band
Image

0 @ O Color Manager - [1] chlor_a

O Basic Sliders Table @

[1) chlor_a X

[E [1] chlor_a

Logyg
Scheme

Default 'chlor_a'™*

— Verda las opciones para Colores wwp e B

LASLIELLE CUiul s

e

2 Mask.. ME-Golox

=l File.. |5 Laye..

16. Bajo Range cambie los valores para
miny max a 0.1y 60
respectivamente

— Vera laimagen de clor_a cambiar
de color

17. Puede seleccionar otra paleta de
colores del menu desplegable bajo
Cpd File > Oceancolor_Standard.cpd
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Cpd File
oceancolor_standard.cpd

LI i

Load cpd file exact values

Reverse Save

Range i %
Min: 0.1 &
Max: 60.0

Set from Band Data l#

¥ Less Options

< %

listogram matc... = None <

lo-data color:

Discrete colors @'

File.. |&Laye. |Z Mmask. [l Golox




Agregar Barra Cromatica

18. En la barra superior seleccione View and/or o p (SRS :
Export the color bar | :

s s@oNe®e AW E
19. Le saldra una ventanilla Create/Edit Color Bar . =

— Mantenga las opciones preprogramadas -~
por ahora — puede explorar las opciones

segln su conveniencia it |
20. Haga clic en la opcion Create Layer en la e
parte inferior derecha del cuadro o
21. Haga clic en Show/Hide map gridlines ~ ==Ey
layer o
S EHEG Ay I | B Imagen con la barra cromatica y lineas de

cuadricula
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Ampliar y Examinar Valores de Clor_a

22. Amplie el Lago Victoria utilizando la
ventanilla Navigation Controls a la

derecha

— O use el menu superior para
ampliar y desplazarse por la
Imagen

OO0  PixelInfo
& Geo-location
Image-X 696 pixel
Image-Y 714 pixel
Longitude 32°14'4... degree
Latitude 1°07'38... degree

23. Mueva el cursor de la computadora
sobre la imagen y fijese en la
ventanilla Rasters a la derecha para
ver valores de latitud-longitud y los
valores de clorofila correspondientes

[E Rasters

chlor_a  31.37337 mg m~-3

B longitude 32.244... degrees...
latitude  -1.127... degrees...
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Guardar el Archivo y la Sesion

24, Para guardar la sesion, primero hay que guardar los
datos en formato BEAM-DIMAP

25. Haga clic con el boton derecho en el nombre del
archivo en la ventanilla File Manager Window y haga clic
Save As

26. Se le pedira que guarde en formato dimap

nnnnnnnn

[1] A2018216112500.L2_LAC_OC.nc
it has to be converted to the BEAM-DIMAP format.

Depending on the product size the convi

Do you really want to convert the pr

Do not show this guestion an

ersion also may take a while.

oduct now?

ymore.

27. Haga clic en Yes y guarde el archivo en formato dim en
su computadora

28. Ahora vaya a File > Session Save y siga los pasos para
ponerle nombre a la sesion (terminando con .seadas) y
guardela

29. Puede abrir esta sesion después utilizando File > Session
Open
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IEZ) Edit View Layer

Open ...
Open Recent
Open Utilities

Close

Save as...

Session Open...

Session Close

Import >

Export >

Export Other »
T

~0 b
>
> &

¥
1




Recortar la Capa Raster

®0e B [1] chlor a

30. Amplie el lago Victoria para que la
ventanilla principal de SeaDAS cubrks
sOlo el area del lago

31. En el menu superior vaya a Raster >
Crop

32. Vera una ventanilla mostrando la
region ampliada a ser recortada

33. Seleccione OK vy le saldra el raster
recortado como una hueva capa EZ5E ocssw Tool

DEM Band ...
Filtered Band...
Math Band...
Real Band

Collocate...

Flip Data...
Image Analysis »>

Level-3 Binning
Mosaic...

Orthorectify... |
Reproject... Estimar
Time Series > | WG | cancel
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Visualizar la Capa Chlor_a Recortada

34. Vera la nueva capa raster recortada
en la ventanilla File Manager

v = [1] A2018216112500.L:
» [ Metadata
» [ Flag Bit Coding
» [ Vectors
v E Rasters
» [ aot
[ angstrom
» [ Rrs
B chlor_a
[ chl_oex
» [ Kd
[ pic

35. Haga clic en Chlor_a para agregar
la capa raster recortada

36. En el menu superior vaya a
Window=->Tile Horizontally para ver
tanto la capa Chlor_a original como - «ommmem
la recortada .

37. Amplie ambas capas para 0 e
asegurarse que la recortada solo ao
cubre el lago Victoria S
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Calcular Estadisticas

38. Seleccione la capa Chlor_a recor-
tada haciendo clic en la ventanilla

39. En el menu superior seleccione
Display Statistics for selected band(s)

GO et s 1
— Se abrird una ventanilla Statistics —
[2]chlor_a

40. Seleccione Run para obtener
estadisticas sobre la Clor_a para el
lago Victoria para el 24 de enero de,
2018
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e

chlor_a
Regional_Pixels
Valid_Pixels
Fraction_Valid
Mean
Standard_Deviation
Variance
Coefficient_of_Variation
Total_Bins
Bin_Width

Bin_Min

Bin_Max
80%Threshold
85%Threshold
90%Threshold
95%Threshold
98%Threshold

Statistics Spreadsheet

Statistics - [2] chlor_a

[ —

File# Band Regional_Mask Quality_

2 chlor_a

158004 QiU Regional  Quality  Criteria
41873
0.2650 and Searc
14.7395 —_—
17.5306 aot_869
iul?é;iza angstrom
1000 Rrs_412
0.0980 Rrs_443
1.8009 Rrs_469
49.7924 Rrs_488
27.8667 o e
34.0402 Select All Select None
41.5856
51.7768
63.8298
Run Reset

»




Diagramar el Histograma

41. Asegurese de estar trabajando con
la capa recortada:

— Nota: puede remover la capa

Chlor_a original haciendo clic en la

X [1]) chlor_a x|[2]{hh::r_a :=-=:|
42. En el menu de la barra superior
seleccione Display Histogram for a
selected ba
| i [ [ 14
— Se abrira una ventanilla titulada
Histogram — [2] chlor_a

43. Seleccione X-Axis > Log 10 scaled
44. Vera un histograma en la ventanilla
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Histogram - [2] chlor_a

Histogram for chlor_a

100

O

Use ROl mask:

L=
£z

#Bins: 512
Logl0 scaled bins

Log10 scaled

HFXes @

ooo o)
mom oo

oo
TR 3

-
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'
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Analisis y Visualizacion de |la Reflectancia de Bandas de MODIS

45. Haga clic en elnombre  46. Haga clic en OK — ————
del archivo de |la capa para obtener una
recortada y seleccione Imagen RGB de
RGB Image color real

] latitude

[ JoN ] Create RGB Image

Profile:

| 7 Metadata ! NASA MODIS L2 Ba®il

» | 7| Flag Bit Coding
¥ | Rasters
k| |aot
(2] angstrom
k| | Rrs
[ chlor_a
[ chl_ocx RGB Image...
[0 Kd I |
[ pic
[ poc
[ ipar
[ nflh
[ par
[3 12_flags

Red: Rrs_667

Geometry Container...

;;;;;;

RGB Image

NASA’s Applied Remote Sensing Training Program 16 .



Sincronizar Imagenes

47. En la barra superior seleccione
Window > Tile Horizontally

48. Vera las imagenes Chlor ay RGB

49. Vaya a la ventanilla Navigation
Control (lado inferior derecho) y
haga clic en el Synchronization Tool

Rrs_443 Invalid ... srA-1

Rrs_531 Invalid ... srA-1

Rrs_667 Invalid ... srA-1

chlor_a Invalid ... mg m#...
tude Invali i

EES ¢ ®

| Snap to selected pin

50. Ahora cuando mueva o recorra una
Imagen en una ventanilla, la otra
ventanilla se movera en conjunto
con ésta

O O O Navigation Contro Is

Synchronise window views of compatible bands fproducts
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Calcular Relaciones entre Bandas de MODIS

51. Vaya a Raster > Math Band ' ® @ Create Logical Expression (Math) Band
b ira ” Target file:
— seabrra unaventaniia L [1] A2018216112500.L2_LAC_OC d

— asegurese que el Target File sea el —
archivo MODIS OC

52. Ingrese LogBandRatio (o el nombre
de su eleccion) en Name: para un
nuevo nombre de raster

Name: LogBandRatio

Description:

! Unit:
I Spectral wavelength: 0.0

Virtual (save expression only, don't store data)

53. Haga clic en Edit EXpreSSion Replace NaN and infinity results by NaM
\ Math Band expression:
\ Edit Expression...

“ Cancel Help

NASA’s Applied Remote Sensing Training Program



Calcular Relaciones entre Bandas de MODIS

54. Se abrira la ventanilla Expression ot souces Emmmd':prm.-m
cditor = =
55. Haga clic en Functions y luego en XX
log10(@) entre las selecciones s -
deSplegableS a;:w bands L‘::-nsta.nts::'.}.J i
56. Ahora resalte la @ en la expresion o s (S
Show single flags TeacLichs i d 5 i 9
57. Ingrese la relacion entre bandas de coes (® GGl
log10(Rrs_443)/(Rrs_555) usando Data =ity S "
Sources a la izquierda y la operacion seanace, )

cail(l)

@/@ en la ventanilla del medio
58. Haga clic en OK
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Calcular Relaciones entre Bandas de MODIS

888 File Manager

59. Regresara a la ventanilla Create X
Logical Expression (Math) Band e

Window

60. Haga clic OK e
. : B chr

61. Le saldra la imagen del B’

Logl10O(Rrs_443/Rrs555)
62. Mueva el cursor para revisar los 5 e

valores de la relacidon entre bandas E—

il S Laye. | 2 Mas. | 8 Col. | 1
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Para Derivar Su Propio Algoritmo

e va a necesitar mediciones in situ de la concentracion de clorofila en el lago

e va a recopilar la relacion anterior para varias imagenes MODIS sobre el lago
Victoria usando OceanColor Web

« calcule el promedio de las relaciones entre bandas MODIS alrededor del punto
de medicion in situ para cada dia

« derive la relacion estadistica entre los datos in situ y aquellos en base a MODIS

Nota: El algoritmo OC Chlor_a es un
polinomio de 4% orden en
Logl1O(Rrs_443/Rrs_555)
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OPCIONAL: Examinar Reflectancias (Rrs) de Bandas Superficiales

] . £ latitude
1. En el File Manager, en la capa que le recorto al lago & [2] A2018216112500.L2

Victoria, haga clic en Rrs para ver varias capas de Metadata
. Flag Bit Coding
reflectancia de bandas

Rasters
aot

2. Haga clic en las capas y observe las caracteristicas en

. _ 2] angstrom
Imagenes correspondientes Rrs
: : : L e : (] Rrs_412 (412
3. Posiblemente quiera repetir el analisis que hizo para la clor_a B Rrs 443 (443 |
(es decir, cambiar colores, calcular estadisticas) [ Rrs_469 (469 |

] Rrs_488 (488 |
B Rrs_531 (531
] Rrs_547 (547 1
[ Rrs_555 (555
[F] Rrs_b645 (645 |
B Rrs_667 (667 |
] Rrs 678 (678 |

Mehior «
=

il e
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Preguntas para la Tarea

Use este enlace al Google Form para contestar las siguientes preguntas:
https.//arset.gsfc.nasa.gov/water/webinars/wq-image-processing

1. ¢Cuales son las unidades de la concentracion de clorofila segun MODIS?
2. ¢Cuales bandas se utilizan para hacer las imagenes RGB?

3. En base a las estadisticas para el lago Victoria, ¢ cual fue el medio y cuanta la
desviacion del estandar de la concentracion de clorofila?

4. En el histograma ¢,cuantos picos distintos puede ver?
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https://arset.gsfc.nasa.gov/water/webinars/wq-image-processing

Gracias
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