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Exercise 1: Change Detection with Visual Inspection and 
Image Subtraction 

Objectives 

• Identify appropriate images for detecting change  
• Identify change visually using a multi-band approach 
• Create a multi-temporal transform and image subtraction to highlight image 

differences 
• Apply a color scheme to visually interpret image change 

 
Overview of Topics 

• Examine image bands and creating multi-band images  
• Visualize change in images from two dates 
• Transform images from two dates using the Normalized Burn Ratio (NBR) 
• Calculate a differenced NBR image to identify changes in the vegetation over the 

same region across two dates 

Tools Needed 

• QGIS 3.2 for Windows and Mac 

Associated Data 

• Landsat 8 Surface Reflectance image of Tanzania (2016) 
• Landsat 5 Surface Reflectance image of Tanzania (1993) 

All associated data must be downloaded from the ARSET website here: 
https://arset.gsfc.nasa.gov/land/webinars/adv-change18  
 
Introduction 

For this exercise we will examine vegetation changes in Tanzania from 1993 to 2016 
using visual investigation and image subtraction techniques. We will use Landsat data 
from these two years. For the first image in 1993, we will use data from Landsat 5, and 
the 2016 imagery will be from Landsat 8.  
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Remember the Landsat data naming convention:  
 
LXSS_LLLL_PPPRRR_YYYYMMDD_yyyymmdd_CC_TX_pp_BAND 
 
L = Landsat 
X = Sensor (“C” = OLI/TIRS combined, “O” = OLI-only, “T” = TIRS-only, “E” = EMT+, 
“TM” = TM, “M” = MSS) 
SS = Satellite (“07” = Landsat 7, “08” = Landsat 8) 
LLLL = Processing correlation level *L1TP/L1GT/L1GS) 
PPP = WRS path  
RRR = WRS row 
YYYYMMDD = Acquisition year (YYYY)/Month(MM)/Day(DD) 
yyyymmdd = Processing year (yyyy)/Month(mm)/Day(dd) 
CC = Collection number (01,02,…) 
TX = Collection Category (“RT” = Real-Time, “T1” = Tier1, “T2” = Tier 2) 
pp = Product Type (sr = surface reflectance) 
BB = Band Number (B1 = band 1, etc.)  
 
Part 1: Imagery Investigation 

1. Download the imagery for this exercise here: 
a. Save to an Exercise1 folder you create on your local computer  

2. Open QGIS 
3. On the top panel click on Layer > Add Layer > Add Raster Layer 
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4. Navigate to your Exercise1 folder and add bands 1-5 and band 7 for the 1993 
image. Select each band, click Add > OK > Close. You may need to reorder the 
bands to ensure they are listed in the Layers panel in order.  
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5. Click on Raster > Miscellaneous > Merge to stack the bands together into one 
image 

a. Click on the  next to Input Layers and click on Select all to select 
each band. Click OK.  

b. Select the Place each input file into a separate band button  
c. Keep the Output data type as the Float32 default 
d. Click on the  next to Merged and select Save to File. Save the new file 

as Tanzania1993.tif in your Exercise1 folder.  
e. Click on Run in Background  
f. Once the processing is complete, click Close 

6. Repeat steps 4 and 5 for the 2016 image. Navigate to your Exercise 1 folder and 
add bands 1-7 for the 2016 image. Select each band, click Add > OK > Close. 
You may need to reorder the bands to ensure they are listed in the Layers panel 
in order. 

7. Click on Raster > Miscellaneous > Merge to stack the bands together into one 
image  

a. Click on the  next to Input Layers and click on each band from the 
2016 image. Click OK.  

b. Select the Place each input file into a separate band button  
c. Keep the Output data type as the Float32 default 
d. Click on the  next to Merged and select Save to File. Save the new file 

as Tanzania2016.tif in your Exercise1 folder.  
e. Click on Run in Background 
f. Once the processing is complete, click Close 

8. Click on the Save Project As  icon to save your project as Exercise1.qgz 
9. Remove all the images, including the new “merged” images except for Band 4 of 

the original 1993 image and Band 5 of the original 2016 image 
a. You can remove multiple images by clicking on them in the Layers Panel 

and right click and select Remove Layer  
10. Click on Layer > Add Layer > Add Raster Layer. Select the Tanzania1993.tif 

and the Tanzania2016.tif and add them to your project. When you merge the 
images QGIS will create a temporary file called Merged in your layers panel, and 
each merged image will have the same name. By removing the temporary 
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merged images and adding in the images you created, this will save confusion in 
the next steps.  

11. Move the Tanzania1993 image on top of the Tanzania2016 image in the Layers 
Panel  

 

Next, we will change the colors of the imagery to make it more visually appealing.  
 

12. For the Tanzania1993 image, zoom into an area without clouds  
13. Right click on the Tanzania1993 image in the Layers Panel and click on 

Properties. A window will pop up and you should be taken directly to the 
Symbology tab.  

a. Leave the Render type as the default Multiband color  
b. Change the Red band to Band 5 
c. Change the Green band to Band 4 
d. Change the Blue band to Band 3 
e. Click Apply 

You should notice that the color in the image changes to show mostly green. Do not 
close the Layer Properties window yet or change the zoom level.  
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14. Click on the drop down arrow next to Min/max value settings  
15. Turn on the Mean +/- standard deviation and ensure the value is set to 2.00 

(this should be the default)  
16. In the drop down next to Statistics extent choose Current canvas  

a. Click Apply, then OK 
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17. Repeat steps 12-16 for the Tanzania2016 image. All steps will be the same, 
except for the color combinations. Use: 

a. Change the Red band to Band 6 
b. Change the Green band to Band 5 
c. Change the Blue band to Band 4 

Remember the differences in the bands for each Landsat sensor. Here is a nice review: 
https://landsat.usgs.gov/what-are-band-designations-landsat-satellites  
 

18. In the Layers Panel, right click on the 1993 image and click on Zoom to Layer. 
Turn the 1993 and 2016 images on and off in the Layers Panel to double check 
to ensure the color combinations are correct and start to visually examine some 
of the differences you see in each image.  

When examining each image, you should see some differences in the vegetation (bright 
green) from 1993 to 2016.  
 
Now we are going to clip the images to remove the clouds you see in the southern 
portion of the 1993 image and along the eastern and western edges of the 2016 image.  
 

19. Along the top panel, select Raster > Extraction > Clip Raster by Extent  
a. Input Layer: Tanzania1993 
b. Clipping extent: 342375, 393255, -1113255, -1068135  
c. Click on the  next to Clipped (extent), select Save to file, and save to 

your Exercise1 folder as Tanzania1993_Clip.tif. Click Save.  
d. Click on Run in Background  
e. Click Close  
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20. Go back to your map. In the Layers Panel turn off all layers except for the new 
Clipped (extent) layer. You will notice that we have clipped a small area of the 
1993 image.  

21. Repeat step 19 for the 2016 image, this time using the new clipped 1993 image 
extent as your extent. Along the top panel, select Raster > Extraction > Clip 
Raster by Extent  

a. Input Layer: Tanzania2016 
b. Clipping extent: Click on the  next to Clipping extent and select Use 

layer/canvas extent. In the pop-up window under Use extent from select 
Clipped (extent). Click OK. 

c. Click on the  next to Clipped (extent) and select Save to file and save 
to your Exercise1 folder as Tanzania2016_Clip.tif and click Save.  

d. Click on Run in Background.  
e. Click Close 

22. You will now notice two clipped (extent) temporary images in the Layers Panel. 
Remove both of the clipped (extent) temporary images and the Tanzania1993 
and Tanzania2016 images by right clicking on them and selecting Remove 
Layer.  

23. Click on the Add Raster  icon or go to Layer > Add Layer > Add Raster 
Layer and add the Tanzania1993_Clip.tif and the Tanzania2016_Clip.tif. 
Ensure that the 1993 image is on top of the 2016 image in the Layers Panel.  
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24. Now you will need to recolor the images like we did in steps 13-16. Right click on 
the Tanzania1993_Clip image in the Layers Panel and click on Properties. A 
window will pop up and you should be taken directly to the Symbology tab.  

a. Leave the Render type as the default Multiband color.  
b. Change the Red band to Band 5 
c. Change the Green band to Band 4 
d. Change the Blue band to Band 3 
e. Click Apply 

25. Click on the drop down arrow next to Min/max value settings  
26. Turn on the Mean +/- standard deviation and ensure the value is set to 2.00 

(this should be the default)  
27. In the drop down next to Statistics extent choose Whole Raster (this is OK 

now, since we have already clipped out the really high reflectance values from 
the clouds) 

a. Click Apply, then OK 
28. Recolor the clipped 2016 image. Remember the difference in the band 

combinations. 
a. Change the Red band to Band 6 
b. Change the Green band to Band 5 
c. Change the Blue band to Band 4 

29. Repeat steps 25-27 to ensure the image statistics are displayed in the same 
manner 

30. Remember to always Save your map along the way  
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Part 2: Visualizing Change  

Now we will do a simple visualization of change using the near-infrared (NIR) band of 
each date. Remember that the Landsat 5 NIR band is band 4 and the Landsat 8 NIR 
band is band 5. You should still have the Band 4 layer of the 1993 image and the Band 
5 layer of the 2016 image in the Layers Panel.  
 
We will begin by combining the NIR bands of the two images to visualize change. We 
will first clip the Band 5 and Band 4 images to the extent of the other images.  
 

1. Along the top panel, select Raster > Extraction > Clip Raster by Extent  
a. Input Layer: LC05_L1TP_166067_19930705_20170118_01_T1_sr_band4 
b. Clipping extent: Click on the  next to Clipping extent and select Use 

layer/canvas extent. In the pop-up window under Use extent from select 
Tanzania1993_Clip and click OK. 

c. Click on the  next to Clipped (extent) and select Save to file and save 
to your Exercise1 folder as Tan1993_band4_Clip.tif and click Save  

d. Click on Run in Background  
e. Click Close 
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2. Repeat for the Band 5 2016 image. Select Raster > Extraction > Clip Raster by 
Extent. 

a. Input Layer: LC08_L1TP_166067_20160704_20180526_01_T1_sr_band5 
b. Clipping extent: Click on the  next to Clipping extent and select Use 

layer/canvas extent. In the pop-up window under Use extent from select 
Tanzania1993_Clip and click OK. 

c. Click on the  next to Clipped (extent) and select Save to file and save 
to your Exercise1 folder as Tan2016_band5_Clip.tif and click Save.  

d. Click on Run in Background 
e. Click Close 

3. Remove the temporary Clipped (extent) images and the original Band 4 and 
Band 5 images from the Layers Panel 

4. Add the Tan1993_band4_Clip.tif and the Tan2016_band5_Clip.tif to the map. 
Ensure the layers are organized as outlined in the image below.  
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Now, we will combine the two NIR images (Band 5 for the 2016 image and Band 4 for 
the 1993 image) and examine changes in the vegetation from 1993 to 2016.  
 

5. Along the top panel, select Raster > Miscellaneous > Merge  
a. Click on the  next to Input Layers and select Tan2016_band5_Clip 

and Tan1993_band4_Clip then click OK. Ensure that Tan2016 is listed 
first (this will become band 1 in the new image) and that Tan1993 is listed 
second (this will become band 2 in the new image). If they are not in this 
order, you can click on the 2016 image and drag it to the top in the 
Multiple selection window.  
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b. Select the Place each input file into a separate band button  
c. Keep the Output data type as the Float32 default 
d. Click on the  next to Merged and select Save to File. Save the new file 

as NIR_2016_1993_Clip.tif in your Exercise1 folder.  
e. Click on Run in Background 
f. Once the processing is complete, click Close 

6. Remove the temporary Merged layer, the Tan2016_band5_Clip layer, and the 
Tan1993_band4_Clip layers from your map. Add the NIR_2016_1993_Clip.tif to 
the map using the Add Raster function.  

Now we will recolor the NIR image to show purple indicating decreases in vegetation, 
green indicating increases in vegetation, and grey indicating no change.  

 
7. Right click on the NIR_2016_1993_Clip image select Properties and go to the 

Symbology tab.  
a. Render Type: Multiband color (default) 
b. Red Band: Band 2 (this is the 1993 NIR band) 
c. Green Band: Band 1 (this is the 2016 NIR band) 
d. Blue Band: Band 2 
e. Contrast enhancement: Stretch to MinMax (default) 
f. Min/max values settings: Mean +/- standard deviation 2 
g. Click Apply 

8. Note the Min and Max values may not show up in the white bars under the Blue 
band. If they don’t then type in the same value that you see for the Red 
band/Band 2 after you click Apply from Step 7. 

9. Click Apply, then OK 
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You can see a lot of purple indicating a decrease in vegetation but you can also see a 
lot of green indicating increased vegetation. Zoom in on a couple areas that are green 
and click the images on and off to see the increased vegetation between 1993 and 
2016. Do the same for a few purple areas to see the decreased vegetation. 
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Part 3: Single-Date Transformations  

Another method to help changes visibly stand out is the multi-temporal transformation. 
There are many types of transformations, so you will first need to decide on what type of 
transformation you would like to perform on your imagery. Each transformation has its 
own advantage. By creating a transformation, you are leveraging multiple bands of 
information to highlight specific information that you are looking for.  
 
The table below describes the purposes of different transformations, as well as their 
formulas. These are some of the common transformations, but there are many more 
that might be useful. For example, if your area of interest has less vegetation and a lot 
of soil, you may want to consider a Soil Adjusted Vegetation Index (SAVI).  

 
Transform Formula Purpose 

Normalized Difference 
Vegetation Index (NDVI) (NIR-RED)/(NIR+RED) 

Differentiates between 
vegetated and non-
vegetated land. Ranges 
from -1 to 1 

Enhanced Vegetation 
Index (EVI) 

2.5*(NIR-
RED)/NIR+6.0*RED-
7.5*BLUE+1.0) 

Alternative to NDVI for 
highlighting vegetation. It is 
sensitive to areas with high 
biomass 

Normalized Burn Ratio 
(NBR) 

(NIR-
SWIR2)/(NIR+SWIR2) 

Highlight burn scars and 
severity. Works well for 
other types of change as 
well. 

 
To highlight a transformation method, we will use the Normalized Burn Ratio. We will 
apply this transformation to the images for each date, then compare the differences in 
these images.  
 

1. Move the NIR_2016_1993_Clip image to the bottom of your Layers Panel. You 
can do this by selecting it and dragging it below the other two layers. 

2. First we will apply the NBR to the Tanzania1993_Clip image. Along the top panel 
select Raster > Raster Calculator  

3. Use the NBR equation within the Raster calculator by double clicking on the 
appropriate band names in the Raster Bands panel. This will automatically add 
them to the Raster calculator expression box. The equation should look like 
this:  
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("Tanzania_1993_clip@4"-"Tanzania_1993_clip@6")/( "Tanzania_1993_clip@4" + 
"Tanzania_1993_clip@6" ) 
 
4. Click on the  next to Output Layer and navigate to your Exercise1 folder and 

save the new image as NBR_1993.tif 
5. Click OK 

 
 

Now we will apply a stretch to the new NBR image.  
 

6. Right click on your NBR_1993 image and go to Properties and the Symbology 
tab.  

a. Render Type: Singleband Pseudocolor 
b. Color Ramp: Spectral 
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7. Click Apply, then OK  
8. Turn off all layers except your NBR_1993 image and your Tanzania1993_Clip 

image. Now click the NBR layer on and off, and continue to switch back between 
those two layers.  

Note how the transformed values and colors relate to features in the image. Red and 
yellow colors indicate little to no vegetation, while green to blue colors indicate higher 
amounts of vegetation. 
 

1. Now we will repeat steps 2-8 for the 2016 image. However, remember that the 
band combinations will be different for the NBR calculation (band 5 (NIR) and 
band 7 (SWIR2)). Along the top panel select Raster > Raster Calculator  

2. Use the NBR equation within Raster calculator by double clicking on the 
appropriate band names in the Raster Bands panel. The equation should look 
like this:  

("Tanzania_2016_clip@5"-"Tanzania_2016_clip@7")/( "Tanzania_2016_clip@5" + 
"Tanzania_2016_clip@7" ) 

 
3. Click on the  next to Output Layer and navigate to your Exercise1 folder and 

save the new image as NBR_2016.tif 
4. Click OK 
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5. Remember to Save your map along the way 
6. Now we will copy the style from the NBR_1993 image to the NBR_2016 image. 

Right click on the NBR_1993 image and click on Styles > Copy Style.  
7. Click on the NBR_2016 image and click on Styles > Paste Style 
8. Now click the NBR_2016 and NBR_1993 layers on and off, and continue to 

switch back between those two layers to examine the differences  

Part 4: Multi-Temporal Transformations  

Now that you have two single date transformations, you can create a layer that shows 
the difference between the two dates by subtracting one from the other. 
 

1. Along the top panel, click on Raster > Raster Calculator 
2. In the Raster calculator expression box, write an expression that subtracts the 

first NBR image (NBR_1993) from the second NBR image (NBR_2016). The 
equation should look like this:  

"NBR_2016@1"-"NBR_1993@1" 
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3. Click on the  next to Output Layer and navigate to your Exercise1 folder and 
save the new image as NBR_Diff.tif 

4. Click OK 

 
 

5. Again, apply a coloration to your new image. Right click on the NBR_diff image, 
click on Properties and go to the Symbology tab.  

a. Render Type: Singleband Pseudocolor 
b. Color Ramp: Spectral 

6. Click Apply, then OK 
7. To make the colors more meaningful, we can change the values assigned to 

each color. Right click on the NBR_diff image, click on Properties and go to the 
Histogram tab.  

8. Click on Compute Histogram 

Most of the values are around 0. The extreme values are below -0.5 and above 0.5. 
This means good breakpoints are -0.5, -0.25, 0, 0.25, 0.5. 
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9. Click on the Symbology tab. Double click on the first number just below Value to 
the left of the red color and input -0.5. Copy the -0.5 under the Value column and 
input it in the same row under the Label column.  

10. Repeat step 9 for each of the consecutive values that we decided would be good 
breakpoints (-0.25, 0, 0.25, 0.5).  

 
 

11. Click Apply, then OK 

The large positive (blue) and large negative (red) values indicate change in the image, 
while the values close to 0 represent little to no change.  
 
Compare this image with the 1993 and 2016 clipped Landsat images to confirm the 
changes you are seeing. What types of patterns do you observe between these 
images?  
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For example, let’s examine one region in the northwestern portion of our images.  
 

 
 
The area in the blue box is heavily vegetated in 1993, as indicated by the dark green. In 
the 2016 image it does not appear to be highly vegetated, but it looks more like bare 
ground. In the differenced NBR image, where we subtracted the 1993 NBR values from 
the 2016 NBR values, you can see negative values in red. This may indicate that a fire 
burned in this area between 1993 and 2016.  
 
Additionally, in the southwestern portion of the dNBR image (far left) image you can see 
an area indicated in dark blue. In the 1993 image this region appears purple, and in the 
2016 image this region appears green. This could also indicate vegetation regrowth 
from 1993 to 2016.  
 
If you would like to see what the area looks like using Google Earth, open Google Earth 
and type Liwale, Tanzania in the Search box. 
 
 
Conclusion 

In this exercise you examined two methods for simple change detection:  
1. visualizing change, and  
2. using transformations to indicate change.  

These are good methods to begin understanding change and why it is happening in a 
specific region. For a more in-depth analysis, you could explore more years to see the 
year of a forest disturbance or use different transformations to understand drought 
conditions over time.  
 
 


